1. Este sitio usa cookies. Para continuar usando este sitio, se debe aceptar nuestro uso de cookies. Más información
    Descartar aviso

Brico-Manual Z4 e85: reequipar espejos abatibles electricamente

Tema en 'BMW Serie Z (1987 - Presente)' iniciado por jpinmej, 13 May 2018.

  1. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    A medida que vaya reequipando los espejos ire actualizando el post.

    El espejo retrovisor exterior estándar del Z es calefactado, con ajuste interior eléctrico y plegado manual. En opción figuraba el espejo electrocromatico/antideslumbramiento, y el plegado automatico del espejo. En este brico explico como reequipar los espejos con todas las funciones. Para ello necesitaremos:

    -2 retrovisores plegables eléctricamente (yo los encontré en eBay.de)...fold in mirror/elektrisch aussenspiegel anklappbaren.
    Difíciles de encontrar a buen precio y que te digan que son abatibles eléctricamente...y que verdaderamente lo sean. Yo estoy esperando el segundo juego, a ver si ahora sí son abatibles eléctricamente..los primeros que vinieron desde USA resultaron ser de plegado manual y antideslumbramiento
    Los abatibles eléctricamente en principio tienen 7 cables...ojo! Los antideslumbramiento y manuales también tienen 7 cables. La diferencia radica en que los plegables automáticamente, entre los 7 cables, hay uno blanco y otro amarillo, al pin 3 y 8 del conector. Si tienen 9 cables son plegables y antideslumbramiento (autodimming/abblendar).

    -Espejos antideslumbramiento. Desconozco precio pues yo ya los tenía y los reutilicé dado que están impecables. Depende de los espejos que compres tal vez tengan dicha función, en mi caso uno estaba amarilleado y el otro perdiendo líquido.
    -el modulo de plegado (42 euros con portes) que va detrás de la guantera:

    [​IMG]

    -botonera del conductor (unos 150 euros en el conce, bueno, y la del acompañante para que ambos mandos se vean igual de nuevos, pijotero que es uno, 36 euros mas). Total unos 700 euros.

    -El cableado si es pre lo debería tener a falta de los 3 cables que van desde la puerta del conductor hasta el retrovisor (pendiente confirmar en mi coche).
    EDITO: el cableado, al menos en el mio, unidad de julio de 2003, viene completo en ambas puertas, , asi como el cableado desde el módulo de plegado hasta las puertas. No he tenido que cablearlas. Desconozco si existe preinstalación en los post. De no tenerlo no habría problema, se puede hacer el cable pues el sistema es bastante sencillo, son 5 cables que salen desde el módulo de plegado hasta los retrovisores, 1 cable al navegador o al DSC, un positivo y un negativo. 8 en total.

    En mi caso, y desconozco el motivo, al anterior dueño de mi coche le molestaba el conector del módulo de plegado y decidió desmontar la guantera, caja de fusibles y revestimiento inferior del salpicadero para cortarlo...a la derecha de los relés color violeta se ven los cables cortados (y ya desencintados por mi)...

    [​IMG]

    Con paciencia y destreza no tuve más remedio que ponerme a identificarlos, cable por cable, color por color, y conectar un metro más de cables para poder trabajar fuera del salpicadero, marcarlos con etiquetas y buscar el conector apropiado en internet:

    [​IMG]

    Tuve suerte y lo encontré. Referencia número 8364646. En unos días ya estaba en casa. Además llego cableado pero por desgracia los cables eran de un diámetro más pequeño según el WDS, así que tuve que tirar de mi banco de órganos particular particular (2 mazos de cable de puerta de e60, uno de motor de e85 y otro de audio/navegación/BT de e83). Aquí el antes y el después, una vez en los pines correctos y el diámetro apropiado:

    [​IMG][​IMG]

    Obviamente para poder aclararme con tanto cable primero me dediqué a estudiar el WDS y hacer un diagrama de cableado:

    [​IMG]

    Ahora toca ir de nuevo al coche para acabar de conectar los cables al conector del módulo de plegado. Para mas coña resulta que en el mazo cortado había 2 cables iguales (rojo/azul), uno para cada puerta, que salen del módulo de plegado, pin 2 a pin 15 de la puerta del conductor, y desde pin 7 a pin 14 de la puerta del acompañante. Al no tener el conector desconocía el número de pin asignado para diferenciarlos, así que sabiendo que en la puerta del acompañante estaba en el pin 14, desmonté el conector de la puerta y tester en mano logré identificarlos y asignar el pin correspondiente en el conector:





    [​IMG][​IMG]

    Y he aquí el cable, ya encintado como de fábrica:

    [​IMG][​IMG]

    Ya con el conector hecho ahora toca instalar el módulo de plegado de los espejos. Hay que acordarse y pedir en el conce las 2 tuercas de plástico para fijar el módulo en los pernos que ya vienen de fábrica debajo del salpicadero:

    [​IMG]

    Aquí estan los espejos abatibles eléctricamente, que tras una larga búsqueda, encontré. El unico "pero" es que no son antideslumbramiento, pero es una cosa que tiene solución, como se verá más adelante:


    [​IMG]

    Y estos son los espejos donantes de la función antideslumbramiento. Vemos el conector adicional con dos cables, uno lila y otro negro/amarillo:


    [​IMG]


    Lo primero que hice fue desmontarlos, empezando por quitar los espejos. Hay multitud de información en el TIS y en internet. Para ello hay que inclinar el espejo hacia abajo todo lo que se pueda, encintar la carcasa y el cristal para no marcarlos, y localizar entre ellos el pestillo de fijación del espejo, que funciona mediante un mecanismo de bayoneta. El pestillo es semicircular, tiene una muesca en medio y para liberar el espejo hay que empujarlo, con un destornillador de punta plana, encintado, hacia la izquierda, en sentido antihorario, tanto en el retrovisor derecho como en el izquierdo. Como tengo retrovisores donantes he podido practicar sin miedo:

    [​IMG]

    Este es el enlace del TIS donde se explica: https://www.newtis.info/tisv2/a/en/...6-mirrors-finishers-ashtrays-consoles/G8pPLZ7

    [​IMG]

    Una vez sacado el cristal, acto seguido hay que quitar el tornillo exterior que está debajo del espejo y fija la tapa inferior del mismo. Luego desde dentro de la carcasa, liberamos una pestaña de fijación, empujamos y sacamos la tapa:

    [​IMG]

    Después simplemente hay que retirar los 4 tornillos Torx que fijan el mecanismo del espejo a la carcasa. También hay que desmontar el mecanismo actuador u orientador del espejo, que son los 3 tornillos Torx perifericos pequeños y uno central, grande. Además la carcasa va encajada mediante 2 patillas, superior e inferior, al mecanismo del espejo. Con tranquilidad y un destornillador plano se puede hacer sin romper ninguna. Este es el resultado, mecanismo arriba, actuador abajo:

    [​IMG][​IMG]
    [​IMG][​IMG]

    Me llamó la atención que tanto como el abatible manual como el eléctrico comparten la estructura y el hueco para el motor, incluso la referencia es la misma, lo cual abre la puerta, a falta de una investigación más detallada, a futuras reequipaciones de manual a automático simplemente comprando el motor y el kit de reparación de engranajes que se encuentra en eBay. Lo único que faltaría sería la pletina atornillada que fija el motor en su sitio.

    Una vez desmontados ambos espejos, lo siguiente es extraer los cables lila y negro/amarillo con el conector al espejo. Esos cables son los que regulan el oscurecimiento del espejo. Para ello hay que desconectar todos los pines del conector negro, despegar la grapa de fijacion (está fijada al cable con cinta aislante) y así podremos deslizar el sello de goma (que evita el paso de humedad al interior) por el cable hasta sacarlo, cortar la funda termoretráctil, tirar desde fuera con cariño y ya está, cable fuera. Luego hay que desencintar el cable y seleccionar los 2 que necesitamos, el lila y el negro/amarillo:

    [​IMG]

    [​IMG]

    [​IMG]

    Ya con los 2 cables en mi poder, ahora es momento de transplantarlos al otro espejo. Para ello iremos pasándolos uno a uno desde la parte exterior, siguiendo el cable principal, hacia el interior. A modo de prueba han quedado así, y viendo lo sencillo que es creo que me voy a animar a desencintar todo el cable y encintarlo nuevamente con los 2 cables extra, para que quede OEM además de evitar hacer el cableado grueso en exceso:

    [​IMG]

    Un truco para encintarlo es sacar casi todo el cable hacia afuera, es decir, hacia el mecanismo del retrovisor, e ir encintando de fuera a adentro, tensando la cinta para que quede lo más fina posible. Así podrás encintar prácticamente todo el cable. De esta manera la cinta se ira superponiendo de fuera a dentro, favoreciendo el avance de los cables cuando traccionemos para volverlos a meter. Cuesta un poco pero guiándolo con maña y paciencia, entra. Una vez pasado el cable hay que continuar encintando, hasta unos 9,5 cm del final del cable (lo había medido antes de desmontar nada).

    Lo siguiente es lograr que el cable no deje pasar la humedad en el punto exacto donde entra al coche. Para ello utilicé funda termoretráctil, de la misma longitud que la funda original, a una distancia del conector de 55,5 cm (medido previamente). Antes de ubicarla en su posición definitiva, apliqué pegamento alrededor del cable, tras lo cual ya puse la funda y la fijé con la pistola de calor, secando el pegamento a la vez y logrando estanqueizar la zona.

    Finalmente metemos el cable por el sello de goma y lo hacemos avanzar hasta la funda termoretráctil. La forma de encintar nos ayuda pero también podemos ayudarnos con 2 alicates pequeños, uno a cada lado del sello de goma, para dilatar los orificios.

    Ya habiendo encintado todo sólo falta volver a fijar los pines en el conector. Éste el el orden:

    1/VERDE: actuador
    3/AMARILLO: plegado
    4/LILA: antideslumbramiento
    5/NEGRO-GRIS: calentamiento
    6/GRIS: actuador
    7/ROJO-GRIS: actuador
    8/BLANCO: plegado
    9/NEGRO-AMARILLO: antideslumbramiento
    10/NEGRO-GRIS: calentamiento

    Así se ve:
    [​IMG]

    Finalmente sólo hay que poner las grapas de fijacion a 29 cm del sello de goma. Este es el resultado final antes de probarlos en el coche y montar carcasa y espejo:
    [​IMG]
    La semana que viene los instalaré en el coche...
     
    Última edición: 21 May 2018 a las 09:54
    inthenight, Vicko, rasputtine y 10 otros les gusta esto.
  2. the manicminer

    the manicminer Forista

    Registrado:
    19 Jun 2013
    Mensajes:
    994
    Me Gusta:
    550
    Modelo:
    320d y Z4 3.0si
    Increíble Brico todo un experto en electricidad del automóvil :p
    Me interesa el tema porque aparcar con columna a derechas si tengo vecino me obliga a bajarme aunque veo del todo imposible hacerlo yo
    Deseando ver el resultado final
     
    A jpinmej y Daniel Sanz les gusta esto.
  3. julfost

    julfost Clan Leader Miembro del Club

    Registrado:
    29 Ago 2009
    Mensajes:
    16.169
    Me Gusta:
    6.177
    Ubicación:
    Sant Fost
    Unete a BMW FAQ Club Unete a BMW FAQ Club Unete a BMW FAQ Club
    Ufff ! Vaya trabajo !! Yo tengo los míos que lo son, pero no funcionan...aunque un día al sacar la llave, se plegaron...he mirado fusibles, los conectores y nada, solo me queda ver si es problema de programación.
     
    A jpinmej le gusta esto.
  4. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Puede ser fallo del modulo de plegado o de la botonera.
     
    A julfost le gusta esto.
  5. julfost

    julfost Clan Leader Miembro del Club

    Registrado:
    29 Ago 2009
    Mensajes:
    16.169
    Me Gusta:
    6.177
    Ubicación:
    Sant Fost
    Unete a BMW FAQ Club Unete a BMW FAQ Club Unete a BMW FAQ Club
    Y como se puede saber que es lo que falla ?
     
  6. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Doy por hecho que no se pliegan ninguno de los 2. Yo intentaria hacer una diagnosis con el BMW scanner o similar a ver que es lo que canta. La otra opcion seria pillar un modulo por internet, que van baratos, y probarlo. La tercera opcion seria cambiar la botonera del conductor por otra, pero me parece muy raro que fallase eso. Me inclino a que el modulo ha muerto.
    Cuando intentas plegarlos hacen algun ruido? Unas veces se rompe el soporte donde el motor hace palanca para plegar el espejo, lei algo al respecto en Z4forum o en Bimmer post, y otras se trata de un problema con el engranaje, del que por lo visto hay despiece en internet.
     
    A julfost le gusta esto.
  7. julfost

    julfost Clan Leader Miembro del Club

    Registrado:
    29 Ago 2009
    Mensajes:
    16.169
    Me Gusta:
    6.177
    Ubicación:
    Sant Fost
    Unete a BMW FAQ Club Unete a BMW FAQ Club Unete a BMW FAQ Club
    No hace ningún tipo de ruido, ni se pliega ninguno (excepto en la ocasión que cité) miraré de hacerle algún tipo de diagnosis y según lo que cante, lo del módulo.

    Gracias y un saludo
     
    A jpinmej le gusta esto.
  8. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Mas que experto, curioso de como funcionan esas cosas. Parece más complicado de lo que es. Lo que más me cuesta son las posiciones imposibles en el reducido espacio y ya el cuerpo lo va notando...que tiempos aquellos en los que me meti en el maletero del Z para cambiar el revestimiento.
    Ya ire informando de las evoluciones a ver si alguien mas se anima...
     
    A Javizquierdo y the manicminer les gusta esto.
  9. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Mantennos informados. Un saludo y suerte.
     
    A julfost le gusta esto.
  10. Javizquierdo

    Javizquierdo Forista Legendario

    Registrado:
    19 Mar 2010
    Mensajes:
    11.949
    Me Gusta:
    4.931
    Ubicación:
    Pozuelo de Alarcon
    Curradisimo! Muchas gracias por compartirlo!
     
    A jpinmej le gusta esto.
  11. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Hoy recogi los espejos en correos, abri la caja alli mismo y efectivamente parece que lleva el cableado correcto, asi que en cuanto pueda retomaré el brico de instalacion.
     
  12. Castanya

    Castanya Forista Senior

    Registrado:
    21 Feb 2011
    Mensajes:
    6.807
    Me Gusta:
    1.076
    Ubicación:
    BCN
    Modelo:
    ZIVMC
    Brico digno de ser fusilado en pdf, para trabajar offline, muy interesante!
    Felicidades
     
    A jpinmej le gusta esto.
  13. rasputtine

    rasputtine Forista

    Registrado:
    10 Ago 2007
    Mensajes:
    3.260
    Me Gusta:
    1.527
    Ubicación:
    ALMERIA
    Modelo:
    Z4 M Coupé
    :amo2::amo2::aplause::aplause::aplause:
     
    A jpinmej le gusta esto.
  14. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Actualizo el tema con los avances de hoy. Muchas gracias a todos por los comentarios, me animan a seguir trabajando en el brico. Mañana sigo transplantando cables, hoy me faltó funda termoretráctil ancha para proteger el cableado.
     
    Última edición: 15 May 2018
  15. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Ayer terminé de cablear los retrovisores. Esta noche intentaré subir las fotos.
     
    A Javizquierdo y rafa Z4 les gusta esto.
  16. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Retrovisores terminados a falta de probarlos en el coche...
     
    A julfost, rafa Z4 y puntoloco les gusta esto.
  17. Fztop

    Fztop En Practicas

    Registrado:
    25 Feb 2018
    Mensajes:
    62
    Me Gusta:
    121
    Hola : lo primero felicitarte por este currado post!! Lo segundo tengo un pequeño problema con mis retrovisores que siempre están calefactados y eso no es normal no?? Gracias !! Saludos!!
     
  18. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Es algo normal. El espejo se mantiene caliente por debajo de los 25°C para prevenir su empañado.
     
  19. Fztop

    Fztop En Practicas

    Registrado:
    25 Feb 2018
    Mensajes:
    62
    Me Gusta:
    121
    Gracias compañero creía que había que desconectarlo, saludos!!
     
  20. julfost

    julfost Clan Leader Miembro del Club

    Registrado:
    29 Ago 2009
    Mensajes:
    16.169
    Me Gusta:
    6.177
    Ubicación:
    Sant Fost
    Unete a BMW FAQ Club Unete a BMW FAQ Club Unete a BMW FAQ Club

    Hola compañero, pues hoy gracias a @Bomarang le hemos metido el BMW scanner y no ha salido ningún error en los dichosos espejos, debería haber salido algo si fuera el módulo ?? Lo de la botonera lo descarto, además está programado para que se plieguen al sacar la llave.

    P.D. La sesión me ha servido para saber que mi unidad lleva suspensión //M...algo que ya sospechaba, por la diferencia de altura con otros.
     
    Última edición: 20 May 2018 a las 18:30
    A rafa Z4 y Bomarang les gusta esto.
  21. Bomarang

    Bomarang Forista

    Registrado:
    10 Mar 2009
    Mensajes:
    2.571
    Me Gusta:
    2.931
    Ubicación:
    Sant Fost de Campsentelles
    Modelo:
    Z4 2.5i & Zoe
    .

    Gracias por nada @julfost ;) , un placer, aunque al final no hayamos podido solucionarlo...al menos, el cierre centralizado... se activa a partir de los 20 km/h? Un saludo !!! :)


    .
     
    A rafa Z4 y julfost les gusta esto.
  22. julfost

    julfost Clan Leader Miembro del Club

    Registrado:
    29 Ago 2009
    Mensajes:
    16.169
    Me Gusta:
    6.177
    Ubicación:
    Sant Fost
    Unete a BMW FAQ Club Unete a BMW FAQ Club Unete a BMW FAQ Club
    Gracias a ti Angel ! No se ha activado el cierre, pero no es algo que me preocupe...las fotos no consigo enviártelas por tapatalk por MP :(

    Un placer como siempre ;)
     
    A Bomarang le gusta esto.
  23. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Si has descartado fusibles y el modulo esta bien yo miraria la botonera que no se haya estropeado el boton de plegado. Con el BMW scanner tendria que haberte saltado algo, open circuit por ejemplo, si el cableado estuviera mal. Yo probaría a buscar una botonera donante de segunda mano y si no le meteria la maquina de diagnosis de BMW.
    Como programaste los espejos para que se plieguen al cerrar el coche?
     
    A julfost le gusta esto.
  24. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    Espejos instalados. Esta noche subo las fotos...
     
  25. julfost

    julfost Clan Leader Miembro del Club

    Registrado:
    29 Ago 2009
    Mensajes:
    16.169
    Me Gusta:
    6.177
    Ubicación:
    Sant Fost
    Unete a BMW FAQ Club Unete a BMW FAQ Club Unete a BMW FAQ Club
    Como te digo, no creo que sea la botonera, porque el día que se plegaron fue al sacar la llave y luego volvieron a su sitio al volver a abrirlo...volveré a repasar los fusibles y si no, miraré el módulo por si veo algo raro...por cierto ! Donde lo compraste tu ??

    Por lo que vimos con el BMW scanner, estaba programado de fábrica.
     
  26. jpinmej

    jpinmej Forista

    Registrado:
    4 Ene 2007
    Mensajes:
    1.344
    Me Gusta:
    492
    Ubicación:
    Santa Cruz de Teneri
    Modelo:
    135i, Z4, 325d
    El modulo en eBay. La botonera en el conce.
     
    A julfost le gusta esto.